End-of-support news

Current support changes

Current OneAgent support changes

OneAgent 1.179 will be the last OneAgent version that supports the following technologies

  • Node.js 6
    • The vendor has de-supported this technology and version with 2019-04-30

Upcoming support changes

Upcoming OneAgent support changes

OneAgent 1.181 will be the last OneAgent version that supports the following technologies

  • Node.js 11
    • The vendor has de-supported this technology and version with 2019-06-30
  • PHP 5.6
    • The vendor has de-supported this technology and version with 2018-12-31

OneAgent 1.183 will be the last OneAgent version that supports the following technologies

  • IBM WebSphere Application Server 8.0
    • The vendor has de-supported this technology and version with 2018-04-31

Upcoming Operating systems support changes

The following operating systems will no longer be supported starting 2020/03/01

The following operating systems will no longer be supported starting 2020/05/01

The following operating systems will no longer be supported starting 2020/07/01

Past support changes

Past OneAgent support changes

OneAgent 1.173 was the last OneAgent version that supported the following technologies

  • Go 1.10
    • The vendor has de-supported this technology and version with 2019-02-25

OneAgent 1.171 was the last OneAgent version that supported the following technologies

  • Go 1.9
    • The vendor has de-supported this technology and version with 2018-08-24

OneAgent 1.169 was the last OneAgent version that supported the following technologies

  • Azul Zulu 10
    • The vendor has de-supported this technology and version with 2018-09-30

OneAgent 1.167 was the last OneAgent version that supported the following technologies

  • Oracle Hotspot JVM 10
    • The vendor has de-supported this technology and version with 2018-09-30
    • Oracle discontinued Premium Support in September 2018. Please consult the Oracle support matrix for further details.
  • OpenJDK 10
    • The vendor has de-supported this technology and version with 2018-09-30
    • Oracle discontinued Premium Support in September 2018. Red Hat, the primary supporter of OpenJDK, has never officially supported OpenJDK v10.

OneAgent 1.163 was the last OneAgent version that supported the following technologies

  • Oracle Hotspot JVM 9
    • The vendor has de-supported this technology and version with 2018-03-31
    • Oracle discontinued Premium Support in 2018-03-31. Please consult the Oracle support matrix for further details.
  • OpenJDK 9
    • The vendor has de-supported this technology and version with 2018-03-31
    • Oracle discontinued Premium Support in 2018-03-31. Red Hat, the primary supporter of OpenJDK, has never officially supported OpenJDK v9.

OneAgent 1.157 was the last OneAgent version that supported the following technologies

  • Go 1.7
    • The vendor has de-supported this technology and version with 2017-08-24
  • Go 1.8
    • The vendor has de-supported this technology and version with 2018-02-16
  • Oracle Hotspot JVM 5
    • The vendor has de-supported this technology and version with 2015-04-30
  • SAP JVM 6
    • The vendor has de-supported this technology and version with 2017-12-31
  • Node.js 4
    • The vendor has de-supported this technology and version with 2018-04-31
  • Node.js 9
    • The vendor has de-supported this technology and version with 2018-06-30

OneAgent 1.135 was the last OneAgent version that supported the following technologies

  • PHP 5.3
    • The vendor has de-supported this technology and version with 2016-07-21
  • PHP 5.4
    • The vendor has de-supported this technology and version with 2015-09-03
  • PHP 5.5
    • The vendor has de-supported this technology and version with 2016-07-21

OneAgent 1.131 was the last OneAgent version that supported the following technologies

  • Node.js 7
    • The vendor has de-supported this technology and version with 2016-07-30

OneAgent 1.129 was the last OneAgent version that supported the following technologies

  • Node.js 0.10
  • Node.js 0.12
    • The vendor has de-supported this technology and version with 2016-12-31
  • Node.js 5
    • The vendor has de-supported this technology and version with 2016-06-30

Past Operating systems support changes

The following operating systems are no longer supported since 2019/03/01

The following operating systems are no longer supported since 2019/01/01

  • Linux OpenSUSE 12.x, 13.x, 42.0-42.2
  • Linux Ubuntu 12.04, 12.10, 13.04, 13.10, 14.10, 15.04, 15.10, 16.10, 17.04
  • Windows Windows 7 and 8.1 8

Other past support changes

Dynatrace OneAgent version 1.173, planned for August 2019, discontinues support for the following technologies, platforms, and components. OneAgent version 1.171 will be the last version that supports:

  • Pivotal Platform PAS version v2.2.x (Pivotal support for this version ends in April 2019. Please consult Pivotal's support matrix for further details.). OneAgent version 1.171 was the last version that supported Pivotal Platform PAS version v2.2.x.

  • Pivotal Platform PAS version v2.1.x (Pivotal support for this version ends in late December 2018. Please consult Pivotal's support matrix for further details.). OneAgent version 1.163 was the last version that supported Pivotal Platform PAS version v2.1.x.

  • Pivotal Platform PAS versions v1.10.x, v1.11.x, and v1.12.x (Pivotal has already discontinued support for these versions. Please consult Pivotal's support matrix for further details.). OneAgent version 1.157 was the last version that supported this.

  • Pivotal Platform PAS version v2.0.x (Pivotal support for this version ends in late September 2018. Please consult Pivotal's support matrix for further details.). OneAgent version 1.157 was the last version that supported this.

  • Kubernetes versions <= 1.6 are no longer actively maintained by the Kubernetes community. OneAgent version 1.155 was the last version that this.

  • OneAgent deployment on the following operating system versions for which the respective providers have discontinued support:

    • Ubuntu 12.04, 12.10, 13.04, 13.10, 14.10, 15.04, 15.10, 16.10, 17.04 (14.04 LTS, 16.04 LTS, as well as 17.10 and above will continue to be supported)
    • Debian 6
    • Fedora 20, 21, 22, 23, 24, 25
    • openSUSE 12.1, 12.2, 12.3, 13.1, 13.2, 42.1, 42.2
    • Windows 8