Flutter

The Flutter plugin allows you to auto-instrument your Flutter app with Dynatrace OneAgent for Android and iOS. It provides an API to add manual instrumentation.

Prerequisites

  • Dynatrace version 1.203+
  • Dart Version 2.4.0+
  • Flutter Version 1.12.0+
  • Gradle 5.x+
  • Supported Webrequest Framework: Dart HttpClient

Set up a Flutter mobile app

  1. From the left-hand menu, select Deploy Dynatrace.
  2. Scroll down and click the Set up mobile monitoring button.
  3. Type in a name for your app and click Monitor mobile app.
  4. Select Flutter as the platform of your mobile app.

The setup wizard guides you through the set-up process.