Prerequisites for the Dynatrace integration in Google Kubernetes Engine (GKE)

To deploy the Dynatrace GCP function in a Kubernetes container, you need to make sure the following GCP and Dynatrace requirements are met.

GCP requirements

Tools

If you run the deployment from GCP Cloud Shell, you don't need to install additional tools.

If you run the deployment from any host with bash, you need to install:

Settings

If you run the deployment on an existing GKE standard cluster, you need to:

If you run the deployment on an existing GKE Autopilot cluster, or on a new Autopilot cluster that will be automatically created by deployment script, there are no additional settings.

Dynatrace requirements

Review the requirements for ActiveGate and tokens as described below.

ActiveGate

For ActiveGate, you have two options:

  • Have the installation script create a dedicated ActiveGate (default option) recommended
  • Use an existing ActiveGate (version 1.213+ required)

Tokens

The requirements for API and PaaS tokens are as follows:

  • Create an API token
  • Enable the following permissions for the API token as needed:
    • To ingest metrics: Ingest metrics (API v2), Read configuration (API v1), Write configuration (API v1)
    • To ingest logs: Ingest logs (API v2)
    • To ingest both logs and metrics: Ingest logs (API v2), Ingest metrics (API v2), Read configuration (API v1), Write configuration (API v1)
  • Create a PaaS token (if you choose to set up a new ActiveGate during deployment)