Install ActiveGate plugin module

To run ActiveGate plugins you need to install the ActiveGate plugin module on the ActiveGate that has access to your remote technology.

Installation of the ActiveGate plugin module is only an Early Adopter Release requirement. The need to install this will be lifted in subsequent releases.

  1. Sign in to Dynatrace and go to Deploy Dynatrace.
  2. Click the Install ActiveGate plugin module button in the ActiveGate plugin module section.
  3. Follow the on-screen instructions. You'll be given a choice to either install a new ActiveGate with the plugin module or add a plugin module to an existing ActiveGate that you will select from the Deployment status page. You can install a new ActiveGate or an ActiveGate plugin module on an existing ActiveGate that is of version 155 or higher.

Next steps

After successful installation, you should see two running services:

  • Dynatrace Gateway responsible for running ActiveGate
  • Dynatrace Remote Plugin Module responsible for running ActiveGate plugin module

ActiveGate is now ready to execute your plugin. Go ahead deploy your first plugin. See Write your first ActiveGate plugin for more information.