Deployment API - Download latest OneAgent

Downloads the latest OneAgent installer. You can check the latest version number with the GET the latest version of OneAgent call.

For the paas or paas-sh installer types, you can get a configuring installer by passing additional parameters.

GET
  • Managed https://{your-domain}/e/{your-environment-id}/api/v1/deployment/installer/agent/{osType}/{installerType}/latest
  • SaaS https://{your-environment-id}.live.dynatrace.com/api/v1/deployment/installer/agent/{osType}/{installerType}/latest

Parameters

Parameter Type Description In Required
If-None-Match string

The ETag of the previous request. Do not download if it matches the ETag of the installer.

header optional
osType string

The operating system of the installer.

The osType element can hold these values.
path required
installerType string

The type of the installer:

  • default: Self-extracting installer for manual installation. Downloads an .exe file for Windows or an .sh file for Unix.
  • default-unattended: Self-extracting installer for unattended installation. Windows only. Downloads a .zip archive, containing the .msi installer and the batch file. This option is deprecated with OneAgent version 1.173
  • paas: Code modules installer. Downloads a *.zip archive, containing the manifest.json file with meta information.
  • paas-sh: Code modules installer. Downloads a self-extracting shell script with the embedded tar.gz archive.
The installerType element can hold these values.
path required
flavor string

The flavor of your Linux distribution.

Set musl for Linux distributions, which are using the musl C standard library, for example Alpine Linux.

Only applicable to the paas and paas-sh installer types.

The flavor element can hold these values.
query optional
arch string

The architecture of your OS:

  • all: Defaults to ppc for AIX or to x86 for other OS types.

  • x86: x86 architecture.

  • ppc: PowerPC architecture, only supported for AIX and Linux.

  • ppcle: PowerPC Little Endian architecture, only supported for Linux.

  • sparc: Sparc architecture, only supported for Solaris.

  • s390: S/390 architecture, only supported for Linux.

Only applicable to the paas and paas-sh installer types.

The arch element can hold these values.
query optional
bitness string

The bitness of your OS. Must be supported by the OS.

Only applicable to the paas and paas-sh installer types.

The bitness element can hold these values.
query optional
include array

The code modules to be included to the installer. You can specify several modules in the following format: include=java&include=dotnet.

Only applicable to the paas and paas-sh installer types.

query optional
skipMetadata boolean

Set true to omit the OneAgent connectivity information from the installer.

Only applicable to the paas and paas-sh installer types.

query optional

Possible values

Possible values for the items element:

  • all
  • java
  • apache
  • nginx
  • nodejs
  • dotnet
  • php
  • go
  • sdk

Possible values for the bitness element:

  • 32
  • 64
  • all

Possible values for the arch element:

  • all
  • ppc
  • ppcle
  • s390
  • sparc
  • x86

Possible values for the flavor element:

  • default
  • musl

Possible values for the installerType element:

  • default
  • default-unattended
  • paas
  • paas-sh

Possible values for the osType element:

  • windows
  • unix
  • aix
  • solaris

Response codes

Code Description
200 Success. The payload contains the installer file.
304 Not modified. You already have the latest version of the installer. The response does not contain a payload.