Extensions 2.0 API - PUT environment configuration

Activates the specified version of an Extensions 2.0 extension.

The request consumes and produces an application/json payload.

PUT
  • Managed https://{your-domain}/e/{your-environment-id}/api/v2/extensions/{extensionName}/environmentConfiguration
  • SaaS https://{your-environment-id}.live.dynatrace.com/api/v2/extensions/{extensionName}/environmentConfiguration
  • Environment ActiveGate https://{your-activegate-domain}/e/{your-environment-id}/api/v2/extensions/{extensionName}/environmentConfiguration

Authentication

To execute this request, you need the Write extension environment configurations (extensionEnvironment.write) permission assigned to your API token. To learn how to obtain and use it, see Tokens and authentication.

Parameters

Parameter Type Description In Required
extensionName string

The name of the requested extension 2.0.

path required
body ExtensionEnvironmentConfigurationVersion

The version of the requested environment configuration.

body optional

Body format

The ExtensionEnvironmentConfigurationVersion object

Element Type Description Required
version string

Extension version

required

Response

Response codes

Code Description
200

Success. Environment configuration updated.

400

Failed. The input is invalid.

404

Failed. The requested resource doesn't exist.

Response body

The ExtensionEnvironmentConfigurationVersion object

Element Type Description
version string

Extension version