Troubleshooting guide

NAM Server

Error rendering reports using Chrome browser


Symptoms

Root cause

This problem is related to the Chrome browser and rendering issues that occur if the NAM Server runs HTTPS with a default self-signed SSL certificate that is not fully trusted by Chrome.

Solution

  • Replace existing self-signed certificate on the NAM Server with a CA signed certificate. Refer to this procedure for details.

  • Try a different browser type (Firefox, Opera, Edge).

  • Refresh the page in the browser (this is only a temporary workaround).

SynchConfigTask execution failed


Symptoms

NAM Server 2018, after upgrade from DC RUM 2017 with ADS in a cluster, displays this error message:

SynchConfigTask execution failed at 05/22/2019 14:10

Root cause

There is still an ADS server (or servers) defined in a cluster configuration on the master NAM Server. An ADS server can no longer be a member of a NAM cluster. The ADS component has been discontinued in the product starting with NAM 2018, and NAM Servers are not backward compatible with ADS servers.

Solution

Open a SQL console on the NAM server that displays the error message. Example URL: https://NAM_SERVER_IP/DiagConsole#/sql

Execute this SQL query:

delete from clusterservers where deleted = 1

Restart the NAM Server service.

Servers, clients, or sites cache limit has been exceeded

Symptoms

The NAM Server displays an error message such as:

Sites cache limit has been exceeded. There are over 20000 sites in the cache, limit is set to 20000(20000).

or the server.log file has an error message such as:

E RTM	19-02-01 09:32:22.836	Cannot create the operation, no more servers allowed
E RTM	19-02-01 09:32:22.836	Failed to save sample: couldn't create the server

Root cause

The servers, clients, or sites cache limits originate from earlier NAM releases, where they were used to control memory utilization on the CAS/NAM Server. Upgrade does not change the values of these settings.

Starting with NAM 2017, these limits no longer play a role and can be safely adjusted to the new default value (max int).

Solution

  1. Open the NAM Server navigation menu.

  2. In the Tools section, select Admin console and then the Capacity properties editor tile.

  3. Set these Target Value limits to the new NAM default value: 2147483647.

  4. Leave Ignore capability recommendations setting to ON.

NAM Server restart is not required but it takes a couple of processing intervals for the new values to take effect.

Operation explorer does not display performance details after upgrade

Symptoms

The Operation explorer does not display the Performance details section, and instead displays an error message such as:

Not valid expression <avDataDet> used in evaluated column calcAvDataDet. Ex: wrong column avDataDet

Root cause

The problem exists when node servers in the cluster have different product versions.

Solution

Upgrade the remaining node servers in the cluster to NAM 2018 or to NAM 2019. All servers must be in the same version.

NAM Probe

rtmhs process does not start after upgrade


Symptoms

After upgrade, the rtmhs process does not start.

Use cases

Root cause

The problem is likely caused by a /var partition mounted in noexec mode. To verify this, run the mount command and check output for the /var mount point:

/dev/sda1 on /boot type ext4 (rw,nosuid,nodev,noexec,relatime,data=ordered)
/dev/mapper/vgroot-lvhome on /home type ext4 (rw,relatime,data=ordered)
/dev/mapper/vgroot-lvvar on /var type ext4 (rw,nosuid,nodev,noexec,relatime,data=ordered)
/dev/mapper/vgroot-lvtmp on /tmp type ext4 (rw,nosuid,nodev,noexec,relatime,data=ordered)

Solution

Re-mount /var with exec mode:

ndstop
mount -o remount,exec /var
ndstart

Add the exec parameter to the /var mount point in the /etc/fstab file to make this change permanent.

NAM Console

NAM Console UI is not reachable after migration


Console cannot start due to some inconsistency in farm configuration stored in NAM Console database

Symptoms

User is getting HTTP error 503

Problem accessing NAM Console

Reason: Service Unavailable

Solution

Stop Dynatrace Watchdog Service and Dynatrace NAM Console service.

Open SQL Management studio, log in as RUN this queries on CVA database:

delete FROM [Console18].[console].[NODE]
delete FROM [Console18].[console].[CLUSTER]
delete FROM [Console18].[console].[FARM]

where Console18 is an example name of your NAM Console database.

Start Dynatrace NAM Console and Dynatrace Watchdog Service.