Backwards compatibility

Some components are backward-compatible with other products and components. The backward compatibility list relates to monitored and stored data only. Compatibility between various releases should be considered a temporary step in the upgrade process. Configuration differences between current and older releases may have an undesired effect on your monitoring and are not recommended for continuous use.

NAM 2018 backward compatibility


Backward compatibility (if any) of NAM 2018 components:

NAM Server

  • CAS 2017
    NAM Server 2018 and CAS 2017 are NOT compatible with each other when the synchronization between servers is in effect, for example in a cluster environment.
  • ADS 2017

NAM Probe

  • TCAM 12.4 and later

NAM Console

  • CAS 2017 (limited configuration ability)
  • AMD 2017
  • ADS 2017

NAM 2018 integrated components compatibility


NAM 2018 and all its updates are compatible with the following versions of integrated components.

AppMon and Gomez

NAM 2018 integrates with AppMon and Gomez, but we plan to discontinue this integration in future releases, so we do not encourage you to integrate with these products.

  • AppMon 6.5  and 2017.
  • Continuous support for integration with Synthetic Monitoring (aka Gomez).
  • Enterprise Synthetic versions 12.5 and 12.4.x

DC RUM 2017 backward compatibility


Backward compatibility (if any) of DC RUM 2017 components:

CAS

  • DC RUM 12.4 and later (recommended release is 12.4 with the latest service pack)
  • RUM Console 2017 (no backward compatibility)

ADS

  • DC RUM 2017 only (no backward compatibility)
  • AMD 12.4 and later (recommended release is 12.4 with the latest service pack)

AMD

  • TCAM 12.4 and later

RUM Console

  • DC RUM 12.4 and later

DC RUM 2017 integrated components compatibility


DC RUM 2017 and all its updates are compatible with the following versions of integrated components.

  • AppMon 6.5  and 2017.
  • Continuous support for integration with Synthetic Monitoring  (aka Gomez).
  • Enterprise Synthetic versions 12.5 and 12.4.x

If you are running an older DC RUM release that does not have a direct upgrade or migration path to release 12.4, you must first get to the minimum release that supports a direct upgrade or migration to release 12.4. Once this intermediate upgrade is successful, proceed with the next upgrade to release 12.4. Review Upgrade Paths to learn how to migrate from earlier releases to a minimum release for a direction migration to 12.4. Go to the Dynatrace Community to find documentation for back releases.

[Link to anchor on page]

Note

You must maintain the DC RUM components in supported and compatible releases throughout the migration process. Failure to do so will impact the availability of monitoring operations.