Supported OS and SQL versions

For hardware specifications, see Hardware requirements and recommendations

Product and component renaming

A reminder on product name changes starting with Network Application Monitoring (NAM) 2018:

DC RUM 2017 May release Dynatrace NAM 2018 release
RUM Console NAM Console
Central Analysis Server (CAS) NAM Server
Advanced Diagnostic Server (ADS) Advanced Diagnostics on Demand feature of NAM Server
Agentless Monitoring Device (AMD) NAM Probe

NAM Server, NAM Console, ADS, CSS


Windows server support overview

Windows Server is now offered in Standard, Datacenter and Essentials editions. We support Standard and Datacenter editions. All Windows based components have the same functionality and performance on either of them. The Essentials edition has too strict restrictions for production deployments. For Windows Server 2016, we also support Server Core installation option.

Microsoft SQL Server support overview

We support both Standard and Enterprise versions of Microsoft SQL Server. Note that all components have the same functionality and performance on Microsoft SQL Standard and Enterprise. We do NOT support Microsoft SQL Express for report server, console, CSS, and Enterprise Synthetic Agent Manager.

See Third-Party Licensing for further information on Microsoft SQL licensing options for your deployment.

Dynatrace NAM 2018 September, SP1

Microsoft Windows

  • Microsoft Windows 2008, 2008 R2
  • Microsoft Windows 2012, 2012 R2
  • Microsoft Windows Server 2016

Microsoft SQL Server

  • Microsoft SQL Server 2008 R2
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2016

NAM Probe


We test Linux with a particular kernel number, as noted in the table below. If Red Hat issues a kernel update, we do NOT recommend installing it before we confirm it does not cause any issues for the NAM Probe (formerly AMD) software.

Red Hat Enterprise Linux

Red Hat Enterprise Linux is sold on a per-socket-pair basis so that the prices in the vendor's directory affect every two populated sockets in the server. Choose a subscription based on the target hardware architecture for your NAM Probe.

Except as noted, the NAM Probe has the same functionality and performance on all versions of the supported versions of Red Hat Enterprise Linux operating system.

CentOS

Starting with the 2017 release, NAM Probe also works with CentOS in releases equivalent to those of Red Hat. Note that Dynatrace does not provide support for the operation and maintenance of your Linux, either Red Hat or CentOS.

Bear in mind that CentOS is supported only in the community model and system updates are sometimes available with a delay to those provided by Red Hat. This can cause short, temporary discrepancies between the two systems.

SELinux
We do not recommend enabling the SELinux option (Security Enhanced Linux). We have observed up to 7% performance degradation with SELinux enabled.

The gcc package
For NAM Probe 2017, if you upgrade the kernel to the latest supported version, you must also upgrade the gcc package to the latest version for that kernel. Your kernel and gcc package should be at the versions recommended by Red Hat.

Dynatrace NAM 2018 SP1

latest supported kernel minimum required kernel
Red Hat Enterprise Linux (7.3, 7.4, 7.5) 64-bit 3.10.0-862.14.6.el7.x86_64 3.10.0-514.26.1.el7.x86_64
CentOS Linux (7.4, 7.5) 64-bit

Dynatrace NAM 2018

latest supported kernel minimum required kernel
Red Hat Enterprise Linux (7.3, 7.4, 7.5) 64-bit 3.10.0-862.14.6.el7.x86_64 3.10.0-514.26.1.el7.x86_64
CentOS Linux (7.4, 7.5) 64-bit

Data Center RUM 2017 May SP6

latest supported kernel minimum required kernel
Red Hat Enterprise Linux (7.3, 7.4, 7.5) 64-bit 3.10.0-862.14.6.el7.x86_64 3.10.0-514.26.1.el7.x86_64
CentOS Linux (7.4, 7.5) 64-bit

Data Center RUM 2017 May SP5

latest supported kernel minimum required kernel
Red Hat Enterprise Linux (7.3, 7.4, 7.5) 64-bit 3.10.0-862.11.6.el7.x86_64 3.10.0-514.26.1.el7.x86_64
CentOS Linux (7.4, 7.5) 64-bit

Data Center RUM 2017 May SP4

latest supported kernel minimum required kernel
Red Hat Enterprise Linux (7.3, 7.4) 64-bit 3.10.0-693.21.1.el7.x86_64 3.10.0-514.26.1.el7.x86_64
CentOS Linux 7.4 64-bit

Data Center RUM 2017 May SP3

latest supported kernel minimum required kernel
Red Hat Enterprise Linux (7.3, 7.4) 64-bit 3.10.0-693.21.1.el7.x86_64 3.10.0-514.26.1.el7.x86_64
CentOS Linux 7.3 64-bit

Data Center RUM 2017 May SP2

latest supported kernel minimum required kernel
Red Hat Enterprise Linux (7.3, 7.4) 64-bit 3.10.0-693.2.2.el7.x86_64 3.10.0-514.26.1.el7.x86_64
CentOS Linux 7.3 64-bit

Data Center RUM 2017 May, and Data Center RUM 2017 May SP1

Starting with the NAM 2017 release, we distribute the AMD only in the high-speed architecture.

DC RUM 2017 reporting (CAS/ADS) and management (RUM Console) is backward compatible with Classic AMDs of the 12.4.13 release and later updates until the DC RUM 12.4.

latest supported kernel minimum required kernel
Red Hat Enterprise Linux 7.3 64-bit 3.10.0-514.26.2.el7.x86_64 3.10.0-514.26.1.el7.x86_64
CentOS Linux 7.3 64-bit

Enterprise Synthetic


Enterprise Synthetic 12.5, 12.5.1 and 12.5.2


Microsoft Windows (Agent Manager) Microsoft Windows (Agent) Microsoft SQL Server
Microsoft Windows Server 2008 R2 SP1 Microsoft Windows Server 2012 Microsoft Windows Server 2012 R2 + Microsoft Windows Server 2016 Microsoft Windows Server 2008 R2 SP1 Microsoft Windows Server 2008 SP2 Microsoft Windows Server 2012 Microsoft Windows Server 2012 R2 + Microsoft Windows Server 2016 Microsoft Windows 7 SP1 Microsoft Windows 8.1 Microsoft Windows 10 Microsoft SQL Server 2008 Microsoft SQL Server 2008 R2 Microsoft SQL Server 2012 Microsoft SQL Server 2014 + Microsoft SQL Server 2016

Dynatrace Network Analyzer (DNA)


Dynatrace Network Analyzer 12.5.x


Microsoft Win (Console) Microsoft Win (Agent)
+ Win 10 Microsoft Windows Server 2012 R2 Microsoft Windows Server 2012 Microsoft Windows8.1 Microsoft Windows8 Microsoft Windows7 SP1 Microsoft Windows Server 2008 R2 SP1 Microsoft Windows Server 2008 SP2 + Microsoft Windows10 Microsoft Windows Server 2012 R2 SVR Core Microsoft Windows Server 2012 SVR Core Microsoft Windows Server 2012 R2 Microsoft Windows Server 2012 Microsoft Windows8.1 Microsoft Windows8 Microsoft Windows7 SP1 Microsoft Windows Server 2008 R2 SVR Core Microsoft Windows Server 2008 R2 SP1 Microsoft Windows Server 2008 SP2

Microsoft SQL SVR Unix Agents
Microsoft SQL Server 2008 Express Microsoft SQL Server 2008 Microsoft SQL Server 2008 R2 Microsoft SQL Server 2012 Express Microsoft SQL Server 2012 IBM AIX 5.3 IBM AIX 6.1 IBM AIX 7.1 Linux 2.6 Intel (libraries required) Linux 2.6 Intel EM64T/AMD64 (libraries required) Linux 3.x Intel long-term stable releases supported by Linux Kernel community Starting with this release, the following are NOT supported: Solaris 8 (SPARC platform only) Solaris 9 (SPARC platform only) Solaris 10 (SPARC & Intel/AMD x86 platforms) HP-UX 11.11 HP-UX 11.23 HP-UX 11.31

Additional DNA requirements:


Web Browser Word Processor
To use the Browser Data Collection (BDC) add-in, one of the supported MSInternet Explorer releases must be installed. If you do not use the BDC, the latest stable release of Mozilla Firefox or Google Chrome can be used for most other functionality. No tablet or smart phone browsers are supported. To use the Transaction Expert tool, one of the listed versions of Microsoft Word must be installed. If you do not use the Transaction Expert tool, you do not need Word or any other word processor.

Additional requirements for DNA 12.5.x


Web Browser Word Processor
Microsoft Internet Explorer 9.0 or later. Compatibility Mode is not supported. Microsoft Word 2007 Microsoft Word 2010 Microsoft Word 2013

Additional requirements for DNA 12.4.x


Web Browser Word Processor
Microsoft Internet Explorer 9.0 or later. Compatibility Mode is not supported. Microsoft Word 2007 Microsoft Word 2010 Microsoft Word 2013

Additional requirements for DNA 12.3.x


Web Browser Word Processor
Microsoft Internet Explorer 9.0 or later. Compatibility Mode is not supported. Microsoft Word 2007 Microsoft Word 2010 Microsoft Word 2013

Additional requirements for DNA 12.2.x


Web Browser Word Processor
Microsoft Internet Explorer 8.0. Compatibility Mode is not supported. Microsoft Word 2007 Microsoft Word 2010 Microsoft Word 2013

Additional requirements for DNA 12.1.x


Web Browser Word Processor
Microsoft Internet Explorer 8.0 or later. Microsoft Word XP Microsoft Word 2003 Microsoft Word 2007 Microsoft Word 2010