Creating a report

Use the DMI tool to create or edit a NAM report.

  • To start editing a totally new report, select Tools ► DMI ► New report on the NAM Server menu. This opens the DMI editor with an empty report definition. Follow the procedure below for an example.
  • To open an existing NAM report in DMI for editing, display the report as usual and then open the report menu and select Edit report.
    Editing a report
    See DMI tour for an example walkthrough.

Defining a simple report

  1. On the NAM Server, select Tools ► DMI  ► New report to open DMI with an empty section ready for you to define.
    DMI - initial screen for new report

  2. Set Display name to the string that will be displayed at the top of the section.
    This is where you say what this section shows.
    In this example, let's use Client site availability.

  3. Select a Section type.
    This is where you define how this section's information will be expressed: as a table, a graphic, a tile, etc.
    In this example, let's start with Table (the default type).

  4. On the Data tab, select the input data for this section.

    1. Click the edit control on the Subject line to display the editing controls for the required data input for this report section.
      edit

      You could now select a different data view from the Data views list, but that's not needed for this example.

    2. Click Dimensions and select a dimension.
      In this example, let's choose Client site from the Client grouping category. You can use the search box to find it quickly. Just type client site and select the matching entry to add it to the Selected dimensions list.

    3. Click Metrics and select a metric.
      In this example, let's choose Availability (total) from the Availability category. Again, the search box is the fastest way to find a metric if you know all or part of the name. Find it and add it to the Selected metrics list.

    4. In the Filters box next to Availability (total) in your Selected metrics list, type <= 50. We will report on client sites whose total availability (this metric) is less than or equal to 50 percent.

  5. Click Display Report to see your report.
    Using the example settings above, you should see something like this in your browser:

    NAM: first report: table

Success! You have already created and displayed a one-section report with a two-column table showing the availability of client sites whose total availability is less than or equal to 50 percent. Now let's see what that looks like as a chart.

  1. Open your report section for editing again:
    NAM: first report: edit section
  2. Change Section type to Chart and then click Display report to show the same data as a chart.
    NAM: first report: chart

It's not very fancy (or perhaps very useful so far), but it works. You have created a report from scratch.

Save it and add it to your dashboard for easy access. You can go back to it later to adjust it and add more sections to build a useful report iteratively.

Copying an existing report

To make your worker faster, easier, and more reliable, copy an existing report and customize it.

  1. Open the dashboard to the All reports tab.
  2. Browse existing reports to find one similar to what you want.
    What to look for:
    • A report that looks like what you want (maybe you like the charts and layout), but you want to show different dimensions and metrics.
    • A report that uses the dimensions and metrics you want to report on, but you want to give it a different look, maybe customize it to impress someone.
    • A report that does exactly what you want, but maybe you need to filter it down to just one customer, one location, etc.
    • A report that does exactly what you want, but you need to add extra text boxes to explain concepts to non-technical people, or to customize it for a third party, or to add non-English text for people who speak another language.
  3. Display the report as usual.
  4. Open the report for editing.
    Edit report
  5. Verify that it has what you need, or at least has something you can easily build on.
    For each section:
    1. Edit the section.
    2. Check the section type.
    3. Check the dimensions and metrics.
    4. Check the output.
  6. Save the report under a new name (the equivalent of Save As).
    1. Select Save from the report menu to open the Save Report window.
      Report save
    2. Give your report a new Report name.
    3. Select the section of reports in which to save it.
      Optional: select <New Section> at the bottom of the list to create a new section for storing reports.
      New section
    4. Click OK to save the report in the selected (or new) section.
  7. Verify that you are working on the copy (with the new name).
  8. Edit the copy.
    Now you can make changes without worrying about what you have done to an existing report.
    • Delete sections you don't need.
    • Delete dimensions and metrics you don't need.
    • Copy sections you want to multiply.
    • Change section types (turn a table into a chart, for example, or copy a table, turn the copied section into a chart, and show it side by side with the table).
    • Add a report-level annotation or section-level annotations, including your company logo and links to your company site.
    • Add a filtering bar to make browsing easier.
    • Add filters to focus the report on certain apps or sites.

Copying a section from one report to another

You can copy a report section from one report to another report. This makes report development easier by reusing tested sections.

  1. Open a report that has a section you want to copy.
  2. Select Edit report.
  3. On the Sections and layout tab, select the section you want to copy and then click the section copy button to copy the selected section to the clipboard.
  4. Open the target report for editing.
    1. To add the copied section to an existing report, display the target report and then select Edit report.
    2. To add the copied section to a new report, select Tools ► DMI ► New report, which opens the DMI editor on the section level, so you then need to go up to the Report definition level.
  5. Click the section paste button to paste the copied section into the new report.

    If there isn't an empty section placeholder, an empty row is added to the end of the report definition and the section is pasted into that row.
  6. Move the section within the report layout as needed.
  7. Double-click the section to edit the section as needed.

Finding your report

To make it easy to find your report, add it to your Favorites page:

  1. Select Home ► Dashboard and switch to the All reports tab.
  2. Find your report.
  3. Click the star icon before your report's name to add your report to the Favorites tab.
    Alternatively, when you display a report, you can click the star icon in the upper left of the report to add that report to (or remove it from) the Favorites tab.
  4. Select Home ► Dashboard again.
    If you have favorited your report, you can now see it on the Favorites tab.

Section types

On the Sections and layout tab, use Section Types to determine the format of a report section.

  • Rich table icon Rich table (applies to NAM 2018) creates a lightweight table (simple columns of data) but each row is expandable. Within each row, you can nest report subsections to display charts, tiles, and counters.
  • Table icon Table creates a static one-level table with access to all dimensions and metrics of all data views.
  • Chart icon  Chart creates a simple chart with access to all dimensions and metrics of all data views.
  • Universal diagram icon  Universal diagram creates a section with an image of your choice, showing monitored data points.
  • Dimension tiles icon Dimension tiles presents each dimension value and the corresponding metrics on a separate tile.
  • Metric tiles icon Metric tiles adds a simple metric tile useful as a base for reports displayed on mobile devices.
  • Color counter icon Color counter presents a dimension broken down by the values of a metric of your choice.
  • Row counter icon Row counter adds a simple row counter useful as a base for reports displayed on mobile devices.
  • Annotation icon Annotation adds simple block of text to the report.
  • Filtering bar Filtering bar adds a dimension filter to control what's displayed on the rest of your report.
  • Twitter timeline icon Twitter timeline creates a section on your report that will post as Twitter tweets.
  • Location status icon Location status (applies to DC RUM 2017) displays two charts showing the network performance of regions, areas, or sites.

See Choosing a report section type for information on section types and how to get started using them.

Layout actions

On the Sections and layout tab, use these basic controls for laying out your report

The first three commands are for making copies of existing sections. You might want to, for example, create a table section and then show the same data in a chart section.

clones the selected section and inserts the clone in the first empty placeholder from the top or, if there is no empty placeholder, it adds the clone to the end of the report. If you accidentally add a section in the wrong place, just drag it to the right place.

 copies the selected section to the clipboard.

pastes the section in the clipboard to the selected location.

The next six commands to insert and delete columns and rows of report section placeholders. This is how you decide the general report layout: create a grid of placeholders, and then add report sections to the grid.

Insert row above adds a row of placeholders above the current section.

Insert row below adds a row of placeholders below the current section.

Insert column left adds a column of placeholders to the left of the current section.

Insert column right adds a column of placeholders to the right of the current section.

Delete row deletes the last empty row. (For when you create a row you don't need.)

Delete column deletes the rightmost empty column. (For when you create a column you don't need.)

Designing a report

Initially, a report consists of one section of table type.

  • To change the default section type, edit basic section settings.
  • To delete the default section, click the Delete section icon.
  • To add new report sections, add placeholders (see above) and then drag and drop section types to the placeholders.
    See Sections and layout tab.
  • To move a section, create a placeholder for it and then drag the section to the new placeholder:
    move section
  • To change a section size, drag the edge of the section in the direction into which you want to expand the section.
    Before dragging the right edge over to fill the empty space:
    expand section - before
    After dragging the right edge over and expanding the section:
    expand section - after

After adding new sections to the report, you can change the space taken by your sections, move them, or swap them. For more information, see Improving your report layout.