KITE tab interface

Contents

Note

Some interface controls are different for non-paying users and Keynote customers.

See also KITE Views.

File tab

This tab is used for basic script file operations, including open script, save script, save script as.

The tab is also used to access help, check for updates, and access KITE Options, where you can customize various settings. The available settings are documented on the Settings help page.

Script tab

This tab is used for all KITE script operations, including recording and playing back scripts for Transaction Perspective and Application Perspective.

Record - Contains the Record button to start script recording for each Keynote service.

The drop-down menu below the Record button provides additional options.

Playback - Controls script playback for open scripts.

Script Repository - Controls the appearance and behavior of the Script Repository. Options vary for different script types, but may include:

  • Manage - Manage local folders scanned by Script Repository.
  • Open - Opens the Script Repository.
  • Rename - Change the currently selected script’s filename.
  • Refresh - Refresh contents shown in the Script Repository.
  • Delete - Deletes the currently selected script.
  • Clone - Clones (copies) the selected script and opens the cloned version.

Script - These controls affect the current script or allow you to open an existing script.

  • Open - Open an existing script.
  • Save - Save the current script.
  • Close - Close the current script without saving.
  • Encrypt - Apply encryption to the current script.
  • Errors - Opens a dialog where you can specify navigation errors to be ignored.

Edit tab

These controls allow you to edit script contents.

Move

Move items up or down within the script.

Clipboard

Cut, Copy, Paste or Delete items within the script.

Performance tab

Test type

Burst - Perform multiple tests of one script at specified intervals.

Burst options:

  • Pause - Specify the number of seconds to wait between script executions.
  • Number of runs - Specify how many times to run the script in Burst mode. Maximum for free users is 2. Maximum for Keynote customers is 10. Maximum for free users is 2. Keynote customers should contact their account team if their login limits them to 2.

Group - Perform one test each of test scripts selected from Script Repository.

Group options:

  • Pause - Specify the number of seconds to wait between script executions.

Control

  • Start/Stop - Start and Stop the Burst or Group test.
  • Play in Firefox - If this option is selected, Firefox will be used for the test.
  • Cache Auto Clear - Clear IE’s Cache before each script playback/recording. This does not affect the ApP simulate browser.

Status

Shows progress of Burst or Group test.

Measurement repository

The Measurement Repository stores results of all tests that have been run for the current script.

  • Delete All - Deletes all test results from the Measurement Repository.
  • Delete - Deletes one or more selected test results from teh Measurement Repository.

Global Network - Enables you to open MyKeynote where you can test a URL or run transaction scripts from selected global locations.

  • Instant Test - Test the performance of your web application using the Keynote test and measurement network, using last mile DSL and high-speed backbone connections.
  • 24x7 Monitoring -
    • Non-Keynote customers: Get a free one week Web application monitoring trial. Your script will run continuously from 10 of the 160 cities in Keynote’s global test and measurement network.
    • Keynote customers: Use the MyKeynote portal to schedule 24x7 monitoring, analyze performance data and create service level reports and alarms.

View tab

Views

This area allows you to choose the KITE views (information panels) that will be displayed.

  • Open Views - Opens the list of available views that you can select.

Start page

  • Start Page - Opens the KITE Start Page where you can access training, faqs, tutorials, the KITE community, and other information.

Results

Allows you to choose which results are displayed.

  • Find in Content - Find text in the downloaded text-based content (more information).
  • Report - Displays the script in non-editable format.
  • Display all page elements - Display all page elements, including page elements fetched from cache.
  • Cached Performance View - In the Transaction Details view, only page elements that were not cached are shown. This view shows which elements will be downloaded if the page is downloaded without clearing the browser cache.
  • View content in single window - View content in single window.
  • Display filtered elements - Display page elements, including any elements removed by filters.

Show/hide

Choose whether to show or hide the Status bar and the Document Workspace bar.

  • Toggle Status Bar - Toggle on or off the Status bar that appears at the bottom of the screen.
  • Document Workspace Bar - Toggle on or off the document workspace bar.
  • Auto Hide MDI Client - Automatically close empty MDI windows.

Content text viewer

  • Find/Find Next - Find text strings in the currently open text.
  • View Whitespaces - Places visible markers in the text to indicate spaces, tabs, etc.
  • Collapse All/Expand All - With hierarchically structured text like CSS or JavaScript, this allows you to hide or show text sections below the top level.
  • Toggle Bookmark - Clicking once adds a bookmark at the location in the text where the cursor is located. Clicking again removes the bookmark.
  • Next/Previous Bookmark - Moves cursor to the next or previous location that has been bookmarked.
  • Options - Opens the Edit Options dialog, where you can chose the way text and syntax are displayed in the Text Viewer.

Window

  • Arrange Windows - Arranges open KITE windows.
  • Switch Windows - Switches between KITE windows.

Working with view panes

KITE uses multiple view panes to display different data views. This highly customizable interface enables you to organize the different KITE views however you wish. You can save your preferred arrangement of panes as named, restorable workspaces.

Pinned and unpinned

Watch video Watch a short demo about pinned and unpinned panes.

Pinned panes stay open. Unpinned panes close when the focus moves elsewhere.

Pinned and unpinned panes

Pinned and unpinned panes

By clicking the push-pin icon in the upper-right, panes can be pinned or unpinned.

Moving and docking panes

Watch video Watch a short demo about moving and docking panes.

Panes can be docked together, with tabs always visible that allow you to select from the available panes.

docked pane

docked pane

You can remove a pane from the tab group by dragging its tab and moving the pane wherever you want it. You can return the separated pane to the group by dragging it back to the tab row, or to the target that appears over the tab group when you drag the separated pane over it.

MDI target

MDI target