Disk space message in log files

Environment

Any AppMon component can show this message, e.g. Server, Collector, Agent, ...

Symptoms

There are many different flavors of problems:

  • Crashing components
  • Failing cleanup task
  • Collector class cache issue
  • Permission issue on the filesystem
  • 3rd party processes consuming the diskspace

Please be aware that this could be due to temporary issues too.

Solution

Please review the components log files for strings "No space left on device" and "There is not enough space on the disk". There are further information on the type of file or data which cannot be written. To verify the components disk space requirements.

Are the requirements met and the component takes more than the dedicated disk space please get in contact with Dynatrace support.

If there is indeed a shortage of diskspace please reach out to your local IT / Operations department, Dynatrace staff cannot resolve this issue.

Root cause

The underlying host of the AppMon component does not have enough free disk space left.