OneAgent

End of Life announcement: Support for older versions of Node.js

Node.js 0.10 and .12 have been End of life for several years. We will remove support for those version with the future version 131.
Node.js 5 has been End of life for since 2016. We will remove support for those version with the future version 131.

End of Life announcement: Support for older versions of Alpine

With end of support for Alpine 3.3 on 2017-11-01, we will remove our support for Alpine 3.3 and older with future version 131.

Java

  • Support for Memory Dumps
  • General availability of Java and IHS support on AIX

Apache Http server

  • General availability of Java and IHS support on AIX

Nginx

  • Support for NGINX >= 1.13.2

.NET

Node.js

  • Support for Memory Dumps

Real user monitoring (JavaScript)

  • Support for Fetch API
  • Improved framework support for Angular 2 and support for Angular 4

General improvements and fixes

Security Gateway

  • Improvements to OpenStack authentication – Ceilometer presence is no longer required to start OpenStack  monitoring